Results 1 to 3 of 3

Thread: Lx7 don’t start up after I unplug them

  1. #1
    Join Date
    19.11.2022
    Posts
    6

    Default Lx7 don’t start up after I unplug them

    Hello to all!
    I have a problem with the three lx7 mitras leds that I own.
    After I unplug the leds from socket and put them again at socket to work, only the GHL logo flashes and the screen at the led is off.
    They only start working if I unplug and re plug the small round cable after the power supply.

    I have: updated 3 lights, check all connection, changed the power supplies from one light to another, tried all the 3 of them being the master unit, tried to work them as stand alone, change the socket that I used.

    None of above solve my problem so any advice will be much appreciated!!

  2. #2
    Join Date
    10.10.2013
    Posts
    751

    Default

    Quote Originally Posted by CarpeDiemIris View Post
    They only start working if I unplug and re plug the small round cable after the power supply.
    Hello,

    So if I understand correctly, they are now working?
    This happens if the time between power outage and repowering is too short.
    It is important to wait about ten seconds after unplugging a Mitras LX7 before plugging it in again (time for the electronic capacitors to drain properly). Otherwise the electronics is in an unstable state which produces the phenomenon described.

    Gaël

  3. #3
    Join Date
    19.11.2022
    Posts
    6

    Default

    Quote Originally Posted by itsmorefun View Post
    Hello,

    So if I understand correctly, they are now working?
    This happens if the time between power outage and repowering is too short.
    It is important to wait about ten seconds after unplugging a Mitras LX7 before plugging it in again (time for the electronic capacitors to drain properly). Otherwise the electronics is in an unstable state which produces the phenomenon described.

    Gaël
    Thank you,
    Actually my problem is that when we have electricity power off and after some hour we have back electricity, the lights don’t start up! So it is much more than some minutes…
    I have mad a ticket number 5366 months before.
    Another yesterday 6422. So I am waiting for a solution. Som other people also had some problems… ticket 3910 for example.
    Last edited by CarpeDiemIris; 19.11.2022 at 22:10.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •