Zeige Ergebnis 1 bis 6 von 6

Thema: P4 Web interface

  1. #1
    Registriert seit
    03.05.2012
    Beiträge
    221

    Standard P4 Web interface

    Hi all,

    I have a P4 which works great with the app on mobile devices through the GHL App. However if I go to the IP address of the P4 I get prompted for username and password which I enter and it accepts but then I just get a blank page with the title GHL Connect. I should be getting my dashboard as per the app - or at least that is how it use to work...

    My Wifi firmware version is - 7084

    1. I have rebooted the P4 multiple times.
    2. The GHL App works on multiple different devices (iOS, Android etc).
    3. MyGHL connect works remotely.
    4. I can ping the device and can see it on the network.



    Any idea what I need to do to get this to work?

  2. #2
    Registriert seit
    04.11.2015
    Beiträge
    998

    Standard

    Hi,

    according to your description the P4-webserver cannot find the file that contains GHL Connect.
    You can check the filesystem status on the Communication in GHL Control Center. If it is not checked, you can easily restore it using the internal update page.

    Call it using the IP-address like so: http://192.168.1.223/update
    Then select the file spiffs.bin from the WiFi-Update-Tool package, which you can download from here: https://www.aquariumcomputer.com/dow...le-esp-update/

    This will take 1-5 minutes until the wifi will be automatically restarted. Check the filesystem status again and if it is checked now, use the ip address in your webbrowser to load GHL Connect again.
    No support or warranty issues over PM! Please send PMs to the moderators only if you have general problems with using the forum! Thanks for helping us to keep the support efficient.
    Kein Support oder Reklamationsabwicklung über PM! Bitte senden Sie an die Moderatoren nur PMs bei allgemeinen Problemen mit der Verwendung des Forums! Danke dass Sie uns dabei helfen, den Support effektiv zu gestalten.

  3. #3
    Registriert seit
    03.05.2012
    Beiträge
    221

    Standard

    Thank you will try. How do I check the filesystem as mentioned above can you post the direct link to that webpage that I can get to. I can get to the /update page and uploaded the latest spiffs.bin now.

    After I updated with the latest spiffs.bin, I got the OK message gave it about 5mins then tried again to get to the we page now I get:
    This 192.168.x.x page can’t be found No webpage was found for the web address: http://192.168.x.x/
    HTTP ERROR 404

    I can still get to the update page though

  4. #4
    Registriert seit
    04.11.2015
    Beiträge
    998

    Standard

    You could try to force reloading the page without using cache. This can be usually done by pressing ctrl+r or just use another web browser for this to test.

    If the 404 error persists, the wifi modules memory might be needed to reconstruct.
    This can only be done with the WiFi-Update-Tool and the USB connection of the P4. Follow this howto: https://www.aquariumcomputer.com/kno...dule-firmware/

    1) Start with 'Blank chip...' 2) Start... 3) Reprogram filesystem

    Note: Blank chip... will erase the stored wifi and email settings. These need to be reconfigured after the firmware is installed again.
    No support or warranty issues over PM! Please send PMs to the moderators only if you have general problems with using the forum! Thanks for helping us to keep the support efficient.
    Kein Support oder Reklamationsabwicklung über PM! Bitte senden Sie an die Moderatoren nur PMs bei allgemeinen Problemen mit der Verwendung des Forums! Danke dass Sie uns dabei helfen, den Support effektiv zu gestalten.

  5. #5
    Registriert seit
    03.05.2012
    Beiträge
    221

    Standard

    ok CTRL+f5 and CTRL + r didnt work will do a blank chip update. Will revert. Btw my P4 firmware is 7.23.

  6. #6
    Registriert seit
    03.05.2012
    Beiträge
    221

    Standard

    So did the following (In Order)
    WififFLash.jpg

    1. Flash Blank Chip --- reboot (otherwise it would not reconnect via COM)
    2. Flashed new firmware --- reboot (otherwise it would not reconnect via COM)
    3. Rebuild filesystem --- reboot (otherwise it would not reconnect via COM)

    Opened GHL control center on PC connect via COM.

    1. Setup Wireless Connection again - Connected
    2. Saved Settings waited a while and Updated View - didnt show anything
    3. Rebooted P4
    4. Reconnected via COM - Wifi Connected and IP address assigned.

    GHL Connect works on iOS and Android.

    Went the the IP address via a web browser on Edge (latest version) did the same thing nothing on the page. Prompted for user and pass and that worked. Opened Firefox loaded up took a very long time spinning eventually showed the initial setup.

    Firmware of WiFi updated from 7023 to 7094
    FirmwareWifi.png

    Firmware of P4 is still 7.23 I dont want to update it as every time I do an P4 update I backup my settings and there are A LOT and try restore and they never restore correctly in addition have to do the recalibration of all the probes again.

Forumregeln

  • Es ist dir nicht erlaubt, neue Themen zu verfassen.
  • Es ist dir nicht erlaubt, auf Beiträge zu antworten.
  • Es ist dir nicht erlaubt, Anhänge hochzuladen.
  • Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.
  •