PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : upgrade problems



JayHoe
30.09.2017, 17:28
As usual my wifi stopped working for no reason weeks ago and hasn't worked since. I got fed up of getting it working nd having it suddenly stop.

Today I wanted to do the upgrades. GCC upgraded to 1.1.0.0 ok and the firmware to 7.08.

I then went to do the wifi upgrade. I followed the video, I am on COM4. My IP address pinged ok and while connected with USB, I opened the ip in a browser to get to the web front end. Selected settings, transfer files and firmware.

I opened programfilex86, v1100>wifi>wififirmware-update-tool>firmware.bin (there are not any other firmware.bins in the usual '4837' type folder). The file checked ok and it started the upgrade and then failed.

All my connection settings reset to 0 and the SSID etc all disappeared. I set it up again, set the setings, saved them and reconnected. It will NOT assign the static IP I set (the same as I have used previously). I have rebooted the P4, rebooted the router and it lost settings again.

Currently I cannot ping the ip address as it just says unreachable. I cannot get the P4 connection page to have an assigned IP. I cannot upgrade the wifi firmware, I cannot connect using my browser to the IP address. I tried to use the wifi firmware update tool but it only offers COM1 and COM3, not COM4.

What they hell do I do?


WHy of why will the P4 not hold and continue to work with wifi but just drop after a few hours/days and not work gain?????

:-(

I am at the end of my tether now. The longest it has ever worked was for about two days. Now I can't complete the wifi upgrade either:-(

JayHoe
30.09.2017, 17:50
I should also add that myghl is flashing on the P4... but I cant connect to it and also there is no wifi light on the P4.

I am sooo disappointed, have been waiting ages for the email functionality and the forthcoming app - remote access was one of the major selling points for me... and I can't do anything to the P4 without a USB cable.

Vinny
30.09.2017, 19:35
If you saw COM 4 during the P4 firmware update, that would belong to the USBVCOM driver which is completely separate from the WiFi module update you tried to do.

When you connect the USB cable to the computer and P4, open device manager and see what COM port number is shown beside the GHL Virtual Communications driver. That is the COM port number to select when you use the WiFi module update tool.

JayHoe
30.09.2017, 20:30
If you saw COM 4 during the P4 firmware update, that would belong to the USBVCOM driver which is completely separate from the WiFi module update you tried to do.

When you connect the USB cable to the computer and P4, open device manager and see what COM port number is shown beside the GHL Virtual Communications driver. That is the COM port number to select when you use the WiFi module update tool.

Hi and thanks (again) Vinny,

I wasn't aware of that! I will try again. However, it still doesn't explain why my IP address won't set up and so can't be pinged.

On the other hand, I have just received an email from the P4 with the values showing instead of tokens - so the P4 upgrade worked but how it is sending anything when it doesn't appear to have a IP and the wifi module hasn't upgraded is a bit puzzling....

As an aside, the switches all show as S1-10 on the email. Is there know way to name them so we can tell which is which?

John

JayHoe
01.10.2017, 13:05
No Success.

Device Manager shows 2 ports, 'Communications port (com1) and USB serial device (com3). If I disconnect my cabe to the P4, then com 3 disappears. I have therefore tried to use the update tool with COM3. It fails with a message saying there is an unhandled exception 'Access to port COM 3 is denied.

I tried to use COM1 and a command window opened and scrolled away with lots of messages about attempting connection and delivering payload and then closed. I powered the p4 down and up but I still don't have wifi. There is no wifi light. My SSID and settings vanished again. I tried to set them up but it still won't accept the assigned IP.

On the comms page at the bottom the signal icon has a red cross. There is nothing in the dbm box, the ip is all 0's. connected as client,, connected with myGHL, connected as access point and file system OK are ALL greyed out. Module firmware shows as zero.

Vinny
02.10.2017, 14:16
With the USB cable connected to the PC and P4, please click on REFRESH PORT, then select COM 3 again.

JayHoe
02.10.2017, 17:04
With the USB cable connected to the PC and P4, please click on REFRESH PORT, then select COM 3 again.

I connected up and GCC still did not have an IP. I used the tool again. I had to refresh as no coms were shown, selected com3 and got the error message. Refreshed again and this time.... it apparently worked.

I repowered the P4 and I have a wifi light. The comms page now shows all the settings and the new firmware version.

Disconnected USB and.... connected via wifi!


Woot! Yay!!!

Many many thanks Vinny.

Vinny
02.10.2017, 18:40
Glad to hear you're up and running now!

redseapen500
27.11.2017, 17:33
i'm trying to update my firmware, but it seems that it freezes in update step 4/5.